MR2100 stops booting at Netgear logo

Topics for Netgear Nighthawks MRxxxx Series Hotspots
Post Reply
Hogwild
Posts: 76
Joined: Fri Dec 17, 2021 4:15 pm
Has thanked: 2 times
Been thanked: 5 times

MR2100 stops booting at Netgear logo

Post by Hogwild »

Hi everyone:

My sister's boyfriend has an MR2100 he's willing to sell us from the UK.

So, first things first, it stops booting at the Netgear logo. Can this be fixed?


Second, will this box even work in Canada? Will it depend on the bands?


Thanks.
Nunyaaa
Posts: 1
Joined: Thu Sep 22, 2022 10:22 am
Has thanked: 0
Been thanked: 0

Re: MR2100 stops booting/setup at Netgear logo

Post by Nunyaaa »

I don't think there's a way to fix it (yet). I've tried finding the answer myself, since I have the same issue with a Verizon Inseego 2100. Both Verizon and Inseego support said that they can't help me since it is out of warranty. Inseego also wasn't willing to charge a fee to fix/replace it.

I saw someone on a deal site say the other day that they had this issue immediately, and since it was under warranty, they think Inseego support reflashed the device for them to fix it... but I have no idea if they actually flashed it, or if they just gave him a replacement device entirely.

Hoping that Rich or someone finds a way to fix this issue. A number of other people are also having this same problem... you'll see the mentions of it on Reddit, VZW product review site, and other places... there's money to be made here definitely.

Edit: Try reaching out to Rich, if you haven't already. He might be able to help (for a cost). This is partly why I'm suggesting you reach out - it sounded like he was able to help someone else with a different hotspot that had a similar sounding issue - https://wirelessjoint.com/viewtopic.php?t=3640
Hogwild
Posts: 76
Joined: Fri Dec 17, 2021 4:15 pm
Has thanked: 2 times
Been thanked: 5 times

Re: MR2100 stops booting/setup at Netgear logo

Post by Hogwild »

I think we're talking about two different things. You have an Inseego MiFi 2100. I have NETGEAR mr2100 (from the UK). Two different devices.

Rich might be able to help you. I'm going to try a few more things on my Netgear before I do anything else. Maybe Netgear support will be helpful, though I doubt it. The last time I called them, the "Tech" could barely spell his own name.
Hogwild
Posts: 76
Joined: Fri Dec 17, 2021 4:15 pm
Has thanked: 2 times
Been thanked: 5 times

Re: MR2100 stops booting at Netgear logo

Post by Hogwild »

EDIT: I figured out how to put this thing into firmware download mode. The question is: Does anyone here have a firmware image for it? Netgear refused to speak to me without paying a fee, even though this and other behaviours clearly indicate a firmware bug.


Anyone know if it's possible to put this in a firmware update mode if it doesn't get past the Netgear logo (with 2 dots highlighted underneath)?
Hogwild
Posts: 76
Joined: Fri Dec 17, 2021 4:15 pm
Has thanked: 2 times
Been thanked: 5 times

Re: MR2100 stops booting at Netgear logo

Post by Hogwild »

I did a whole lot of Googling on this and learned neither that Netgear nor the carriers appear to share firmware images for this device. I asked a lot of people and no one had it on disk or had heard of anyone who had it.

The freezing part way through boot and/or boot loop are known bugs. I believe it'they're fixed in a later firmware version, but Netgear won't tell me anything unless i pay for a support incident, and their "techs" are so incompetent I wouldn't trust them to do it after that.

Rich Hathaway told me the boot process may be encrypted, as it is with the MR5xx series. That would be unfortunate, because even if I could get firmware it would be a lot of work to get it to work. The mr1100, of course, did not use Secure Boot.
Post Reply

Return to “Nighthawks MR1100 - MR5200 (M1...M5...)”